Updating rubygems on leopard

08-Feb-2016 10:45 by 4 Comments

Updating rubygems on leopard - Adult Chat Rooms

You continue using whatever interpreter you have set in that shell (whether by default or because you switched manually earlier in the shell session).As an example, my default interpreter is Ruby 1.9.2.

updating rubygems on leopard-37updating rubygems on leopard-54updating rubygems on leopard-46updating rubygems on leopard-3

It should remove all previous installed gems and downloaded libraries so that I now exactly what will happen.The not so ideal world The recommend way is to run So the error actual is that you can't uninstall the System gems with the gem cleanup command, and the error is rather cryptic.Manual uninstall - almost there If you really want to uninstall them , you can uninstall them manually.Updating Ruby Gems Updating rubygems-update Successfully installed rubygems-update-1.3.7 Updating Ruby Gems to 1.3.7 Installing Ruby Gems 1.3.7 Ruby Gems 1.3.7 installed [...] Ruby Gems installed the following executables: /Users/douglassellers/.rvm/rubies/ree-1.8.7-2010.02/bin/gem I have verified this. And unlike other languages everything happens mostly in terminal, so next thing I know – I have to use command line now.I tried few tutorials here and there but couldn’t find anything that explained how to properly install ruby and rails step by step, something for ruby beginners. I’m using mac and ruby 1.8.7 is pre-installed with Mac OS 10.6 Snow Leopard or later.

From time to time , i really need to clean out my mac.

For this new project I wanted to have a clean installation for Ruby and Rails.

The strangest thing is that ruby gems seems to think it is updating the correct file.

It says updating ~/.rvm/rubies/ree-1.8.7-2010.02/bin/gem and when I do "which gem" it points at ~/.rvm/rubies/ree-1.8.7-2010.02/bin/gem.

So there must be another version of gem in the require path?

I can't see one though., but it doesn't switch you to that particular Ruby interpreter.